Some Square payments are failing to process
Incident Report for Jane
Resolved
Looks like we're in the clear. Apologies for the rocky end to the work week! Have a great weekend.
Posted Mar 26, 2021 - 16:29 PDT
Monitoring
Square seems to have resolved the challenges with their payment services. We're still going to keep a close eye on it for a little while though.
Posted Mar 26, 2021 - 15:30 PDT
Update
Square's payment system is still experiencing some challenges.

Their Engineering team has confirmed that they identified the root cause of the issues, and are impacting working diligently to implement a fix.
Posted Mar 26, 2021 - 14:57 PDT
Identified
Square's payment system is currently experiencing some trouble. Their team is aware of the issue and is working on a resolution as swiftly as possible. We'll update this incident when more information is available.
Posted Mar 26, 2021 - 14:25 PDT
This incident affected: Web App - Canada and Web App - US West.