Slow Response Times
Incident Report for Jane
Resolved
This incident has been resolved.
Posted Jul 17, 2018 - 10:32 PDT
Update
We are continuing to investigate this issue.
Posted Jul 17, 2018 - 10:25 PDT
Investigating
Our team is investigating reports of slow response times...
Posted Jul 17, 2018 - 10:22 PDT