Marketing, Guide and Accounts Temporarily Unavailable
Incident Report for Jane
Resolved
This incident has been resolved.
Posted Jun 20, 2018 - 22:57 PDT
Investigating
Jane is all good, but our marketing website (jane.app), the Jane guide, and Jane's sign up page is temporarily unavailable due to data centre outage.
Posted Jun 20, 2018 - 21:37 PDT