Reporting Delays
Incident Report for Jane
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 12, 2018 - 15:47 PDT
Monitoring
We're back to normal. Thanks again for your patience.
Posted 2 months ago. Sep 12, 2018 - 15:36 PDT
Investigating
Jane's reports are loading slower than expected right now. Thanks for your patience while we sort it out.
Posted 2 months ago. Sep 12, 2018 - 15:28 PDT
This incident affected: Web App - Canada East.