Payment Processing Unavailable
Incident Report for Jane
Resolved
Payfirma has reported that the issue has been resolved.
Posted 3 months ago. May 31, 2018 - 14:29 PDT
Identified
Payfirma, one of Jane's payment processors, is experiencing a temporary outage. We will post updates here as we get more info about the outage.
Posted 3 months ago. May 31, 2018 - 14:14 PDT