Payfirma not currently processing payments
Incident Report for Jane
Resolved
This incident has been resolved.
Posted Feb 18, 2020 - 13:14 PST
Monitoring
Payfirma payments are now processing successfully but we’ll be keeping an extra close eye on things over the next little while.
Posted Feb 18, 2020 - 13:03 PST
Identified
We're currently working with the Payfirma team to resolve payment challenges. Clinics using Jane Payments through Stripe are unaffected, though.
Posted Feb 18, 2020 - 12:37 PST
This incident affected: Web App - Canada and Web App - US West.