Partial SMS Reminder Failure for BC/AB
Incident Report for Jane
Resolved
As a precaution, we have sent a "fallback email reminder" to all clients in BC and AB that should have received a SMS reminder yesterday. These only went out to clients whose appointment had not happened yet.
Posted 2 months ago. Oct 11, 2018 - 10:29 PDT
Update
Important Details found on our Status Page
Posted 2 months ago. Oct 11, 2018 - 08:56 PDT
Update
This message about SMS Carrier Filtering by Telus only affects clients in BC and Alberta and is limited to clients on the Telus network.

The Telus network began blocking a number of Jane's outgoing SMS text reminders yesterday morning. Jane identified the outgoing numbers that were being blocked and implemented new ones to avoid the blocks. Messages sent out yesterday (possibly reminding clients about appointments for today if they are 24 hour notifications) may not have been delivered even though they appear to be sent successfully within Jane because Telus was filtering them out at the carrier level.

While normal failures are visible, unfortunately Telus chose not to send back a failure notification, so there is not a way to display which messages were intercepted.

This means that you could have clients on the Telus network who DID NOT RECEIVE their SMS reminders for appointments where the appointment reminders were sent out yesterday morning - this would be today for a 24 hour reminder, tomorrow for a 48 hour reminder and so on.

You can see the notification history of your appointments on the schedule by clicking on the appointment and then scrolling down to the "History and Status" tab to see if and when the SMS reminder was sent.

If you have questions please feel free to contact us for further information.

More info on CASL and SMS Filtering:

Due to the increasingly heavy CASL restrictions (Canadian Anti-Spam Legislation) some carriers are filtering what is called "Application-To-Peer (A2P)" messaging (ie automated to human). It's sort of the equivalent to emails ending up in the Spam folder, the difference being that with text there is no spam folder to check. The messages get sent out normally but then the carrier does not deliver them at all.

This is something that is hard to get around since the message is being rejected by the carrier before it even reaches the device. We see the message being delivered because the carrier does not alert us to the filter (because they are trying to avoid spammers from knowing how to avoid the filters).

Jane's reminders have much of the same content in every message and are often sent out multiple times to the same numbers. This can take on the appearance of Spam. Jane will continue to work to identify ways to avoid being trapped in these filters for messages that your clients not only want to receive, but actively rely on!

A final note that, as mentioned above, Jane has implemented new numbers to avoid the block, so the number from which your clients receive their reminders may have changed.
Posted 2 months ago. Oct 11, 2018 - 08:54 PDT
Identified
Visit jane.app/blog for important information
Posted 2 months ago. Oct 11, 2018 - 08:53 PDT
This incident affected: Email / SMS Delivery.