Reporting system is temporarily delayed
Incident Report for Jane
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 31, 2018 - 23:05 PDT
Investigating
Jane's reporting service is currently unavailable. We are working to restore service as soon as possible.
Posted 3 months ago. Aug 31, 2018 - 22:55 PDT
This incident affected: Web App - Canada East.