Jane is 100% Up, but there are outages on the internet affecting some customers
Incident Report for Jane
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 30, 2018 - 05:34 PDT
Investigating
We are hearing reports of outages across the US preventing customers from accessing many websites, including Jane. This one is unfortunately outside of our control.

Our best tip is to try another internet connection if you have one, such as tethering to your mobile phone.

Here is a link to some information about the storm that is brewing on the internet this morning:
http://downdetector.com/status/comcast-xfinity/map/
Posted 5 months ago. Jun 29, 2018 - 10:24 PDT