Payfirma not currently processing some payments
Incident Report for Jane
Resolved
This incident has been resolved.
Posted May 22, 2020 - 14:26 PDT
Monitoring
It looks like the Payfirma team has restored payments. We’re watching things carefully, and we’ll update you here if there are continued issues.
Posted May 22, 2020 - 14:16 PDT
Update
Payfirma payment processing is still experiencing an issue, but the Payfirma team is working on it! Jane Payments through Stripe is unaffected.
Posted May 22, 2020 - 14:07 PDT
Investigating
We’re currently working with the Payfirma team to resolve payment challenges. Clinics using Jane Payments through Stripe are unaffected.
Posted May 22, 2020 - 13:50 PDT
This incident affected: Web App - Canada Central, Web App - Canada Central 2, Web App - Canada Central 3, Web App - Canada East, and Web App - US West.