Payfirma not currently processing some payments
Incident Report for Jane
Resolved
This incident has been resolved.
Posted May 12, 2020 - 09:56 PDT
Monitoring
It looks like the Payfirma team has restored payments. We’re watching things carefully, and we’ll update you here if there are continued issues.
Posted May 12, 2020 - 09:41 PDT
Update
Payfirma payment processing is still experiencing an issue. The Payfirma team is aware and working on getting payments back up and running. Jane Payments through Stripe is unaffected.
Posted May 12, 2020 - 09:33 PDT
Investigating
We’re currently working with the Payfirma team to resolve payment challenges. Clinics using Jane Payments through Stripe are unaffected.
Posted May 12, 2020 - 09:18 PDT
This incident affected: Web App - Canada Central, Web App - Canada Central 2, Web App - Canada Central 3, Web App - Canada East, and Web App - US West.