Payfirma not currently processing some payments
Incident Report for Jane
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 13:25 PDT
Monitoring
Payfirma payments are now processing successfully but we’ll be keeping an extra close eye on things over the next little while
Posted Mar 16, 2020 - 13:13 PDT
Investigating
We're currently working with the Payfirma team to resolve payment challenges. Clinics using Jane Payments through Stripe are unaffected.
Posted Mar 16, 2020 - 12:56 PDT
This incident affected: Web App - Canada Central, Web App - Canada Central 2, Web App - Canada Central 3, Web App - Canada East, and Web App - US West.