Payfirma not currently processing some payments
Incident Report for Jane
Resolved
This incident has been resolved.
Posted May 20, 2020 - 14:06 PDT
Monitoring
It looks like payments through Payfirma are processing again now, but we’re watching things carefully and we’ll update things here if there are continued issues.
Posted May 20, 2020 - 13:56 PDT
Update
Payfirma payment processing is still experiencing an issue but the Payfirma team is working on getting payments back up and running. Jane Payments through Stripe is unaffected.
Posted May 20, 2020 - 13:53 PDT
Investigating
We’re currently working with the Payfirma team to resolve payment challenges. Clinics using Jane Payments through Stripe are unaffected.
Posted May 20, 2020 - 13:38 PDT
This incident affected: Web App - Canada Central, Web App - Canada Central 2, Web App - Canada Central 3, Web App - Canada East, and Web App - US West.