Payfirma not currently processing some payments
Incident Report for Jane
Resolved
This incident has been resolved ✅
Posted Jun 29, 2021 - 10:49 PDT
Monitoring
Looking like we're in the clear! We'll continue to closely monitor payments through our Payfirma integration for a little bit.
Posted Jun 29, 2021 - 10:33 PDT
Update
The Payfirma Team is still investigating the source of the payment challenges, and we'll continue to update you here when we have more information. Clinics using Jane Payments through Stripe or Square are unaffected.
Posted Jun 29, 2021 - 10:24 PDT
Investigating
We’re currently working with the Payfirma team to resolve payment challenges. Clinics using Jane Payments through Stripe or Square are unaffected.
Posted Jun 29, 2021 - 10:05 PDT
This incident affected: Web App - Canada and Web App - US West.