Jane Payments powered by Payfirma are not being processed
Incident Report for Jane
Resolved
All Payfirma powered Jane Payments are processing normally again.
Posted 6 months ago. Apr 17, 2019 - 11:10 PDT
Identified
Payfirma is making process identifying the issue as payments are starting to get processed now.
Posted 6 months ago. Apr 17, 2019 - 11:06 PDT
Investigating
For customers who have Jane Payments powered by Payfirma, the payments are not being processed currently. We're working with Payfirma to find out what is happening right now.

Note that Jane Payments powered by Stripe is NOT affected (you'll be using Stripe if you signed up for Jane Payments after mid-October).
Posted 6 months ago. Apr 17, 2019 - 10:55 PDT
This incident affected: Web App - Canada Central, Web App - Canada Central 2, Web App - Canada Central 3, Web App - Canada East, and Web App - US West.