Payfirma not currently processing some payments
Incident Report for Jane
Resolved
Payfirma payments appear to be processing normally now.
Posted Aug 08, 2020 - 14:43 PDT
Monitoring
Payfirma payments appear to be restored now. We'll keep a close eye on it for the next little while.
Posted Aug 08, 2020 - 14:26 PDT
Update
Payfirma continues to work on a fix for today's payment challenges. Clinics using Jane Payments through Stripe are still not affected.
Posted Aug 08, 2020 - 14:15 PDT
Update
Payfirma is still working on a fix for today's payment challenges. Clinics using Jane Payments through Stripe are not affected.
Posted Aug 08, 2020 - 13:18 PDT
Update
Payfirma is continuing to investigate and fix the source of today's payment challenges. Clinics using Jane Payments through Stripe are not affected.
Posted Aug 08, 2020 - 12:36 PDT
Update
The Payfirma Team continues to try and fix the current payment challenges. Clinics using Jane Payments through Stripe are unaffected.
Posted Aug 08, 2020 - 12:05 PDT
Update
The Payfirma Team is still hard at work resolving the current payment challenges. Clinics using Jane Payments through Stripe are unaffected.
Posted Aug 08, 2020 - 11:34 PDT
Update
The Payfirma Team is hard at work resolving some payment challenges. Clinics using Jane Payments through Stripe are unaffected.
Posted Aug 08, 2020 - 10:59 PDT
Investigating
We’re currently working with the Payfirma team to resolve payment challenges. Clinics using Jane Payments through Stripe are unaffected.
Posted Aug 08, 2020 - 10:28 PDT
This incident affected: Web App - Canada and Web App - US West.