Square is experiencing some service issues
Incident Report for Jane
Resolved
All sources indicate we're in the clear! We'll still be keeping an eye on things behind the scenes. Have a lovely rest of your day, everyone.
Posted Feb 10, 2022 - 13:43 PST
Monitoring
Square has released a fix for issues they were experiencing today. You should see everything return to normal very shortly.
Posted Feb 10, 2022 - 12:40 PST
Investigating
Square is currently having some performance issues across their services, which is causing payments to fail. We'll keep you updated when they're running at 100% again. You can keep updated on their status here too: https://issquareup.com/
Posted Feb 10, 2022 - 11:52 PST
This incident affected: Web App - Canada and Web App - US West.